このトピックでは、ABAP エージェント、HTTP SDK、および Datavard Insights でサポートされる SAP 環境を示します。

SAP アプリケーション

次の表に、SAP アプリケーションとサポートされるバージョンおよびその他の詳細を示します。

アプリケーション

バージョン

プラットフォーム

機能

タイプ

パッケージ

備考

SAP NetWeaver ABAP

7.0 EHP1 SP15+
7.0 EHP2 SP15+
7.1 SP17+
7.1 EHP1 SP13+
7.3 SP11+
7.3 EHP1 SP09+

サポートされる OS

プロキシ Linux サーバを介した他の OS

RFC、HTTP、Fiori、BSP、WebDynpro、SAPGUIビジネストランザクションABAP エージェントコア

ABAP トレースと DB トレースはサポートされていません

バージョン 7.4 SP06 ~ SP08 の SAP システムでは、このパッケージを使用できます。

SAP NetWeaver ABAP7.0 EHP1 SP15+
7.0 EHP2 SP15+
7.1 SP17+
7.1 EHP1 SP13+
7.3 SP11+
7.3 EHP1 SP09+

サポートされる OS

プロキシ Linux サーバを介した他の OS

NetWeaver Gateway(OData)ビジネストランザクションABAP エージェント BEP

SAP_GWFND コンポーネントがない古い NetWeaver Gateway システムを対象としています。

最小コンポーネント要件:

  • IW_BEP 200 SP10+
  • IW_FND 240 SP06+


SAP NetWeaver ABAP

7.4 SP09+

7.5 ~ 7.54(S/4 HANA 1909 まで)

サポートされる OS

プロキシ Linux サーバを介した他の OS

RFC、HTTP、Fiori、BSP、WebDynpro、SAPGUI、WebGUI、
ABAP および DB トレース、NetWeaver Gateway(OData)、RUM
ビジネストランザクションABAP エージェント 740
SAP NetWeaver ABAP7.0 SP25 ~ 7.54(S/4 HANA 1909 まで)

サポートされる OS

プロキシ Linux サーバを介した他の OS

モニタリング:SAP アプリケーションサーバ - CPU、メモリ、ディスク
DB ベンチマーク、ジョブ、ワークロード統計、ロック統計、
トランスポートエラー、アプリケーションログエラー、ABAP ダンプ
分析Datavard Insights
SAP S/4 HANAS/4 HANA 1909 まで

サポートされる OS

プロキシ Linux サーバを介した他の OS

RFC、HTTP、Fiori、BSP、WebDynpro、SAPGUI、WebGUI、
ABAP および DB トレース、NetWeaver Gateway(OData)、RUM

ビジネストランザクション

ABAP エージェント 740
SAP CRM7.0 BBPCRM 700 SP18 以降NetWeaver ABAPBSP/CRM WebClient UI ビジネストランザクション検出ビジネストランザクションABAP エージェント
SAP IS-U

7.4 SP09+

7.5 ~ 7.54(S/4 HANA 1909 まで)

NetWeaver ABAPRFC、HTTP、Fiori、BSP、WebDynpro、WebGUI、
ABAP および DB トレース、NetWeaver Gateway(OData)、CIC0
ビジネストランザクションIS-U 用 ABAP エージェントフロントオフィスプロセスに基づく
CIC0 ビジネストランザクション分割
SAP PI/PO

7.4 シングルスタック(Java)

7.5 シングルスタック(Java)以降

NetWeaver JavaSAP PI/PO AS Java」を参照ビジネストランザクションと分析Java エージェント + JCo 拡張および Datavard Insights
SAP Portal7.1、SAP JVM 5.1(JDK 1.5)以降NetWeaver JavaHTTP、RFCビジネストランザクションJava エージェント + JCo 拡張

Java エージェントでサポートされる Web アプリケーション

JCo プラグインでサポートされる ABAP への RFC 接続

ABAP から Java へのコールについては、ABAP コードの変更が必要です。「カスタム ABAP コードのインストゥルメント化」を参照してください


SAP サポート通信テクノロジー

次の表に、SAP システムと外部アプリケーション間の通信で使用する、サポートされているプロトコルを示します。

Platform

プロトコル

方向

パッケージ

タイプ(Type)

コメント

NetWeaver ABAPRFC双方向ABAP エージェントビジネストランザクションと分析

ABAP から ABAP、ABAP から Java、および ABAP 発信コールでは、RFC 汎用モジュールごとに ABAP コードを拡張する必要があります。

Datavard Insights を使用してモニタリングが可能

NetWeaver ABAPHTTP双方向ABAP エージェントビジネストランザクション
NetWeaver ABAPWebservices双方向ABAP エージェントビジネストランザクション


NetWeaver ABAPOData双方向ABAP エージェントビジネストランザクション
NetWeaver JavaRFC双方向ABAP エージェントビジネストランザクションJava エージェントの JCo 拡張が必要です。ABAP から Java RFC へのコールについては、ABAP コードの変更が必要です。「カスタム ABAP コードのインストゥルメント化」を参照してください
NetWeaver JavaHTTP双方向ABAP エージェントビジネストランザクションJava エージェントによるサポート
すべての Java アプリケーションRFC双方向ABAP エージェントビジネストランザクション

Java エージェントの JCo 拡張が必要です。ABAP から Java RFC へのコールについては、ABAP コードの変更が必要です。「カスタム ABAP コードのインストゥルメント化」を参照してください

SAP サポート UI テクノロジー

次の表に、SAP アプリケーションで使用する、サポートされているユーザインターフェイス テクノロジーを示します。

プラットフォーム

UI テクノロジー

パッケージ

タイプ(Type)

Comment

NetWeaver ABAPSAPGUIABAP エージェント分析とビジネストランザクショントランザクション パフォーマンス モニタリング - ワークロード統計
NetWeaver ABAPFiori/SAPUI5ABAP エージェントビジネストランザクションと RUM


NetWeaver ABAPBSPABAP エージェントビジネストランザクションと RUMRUM ベータ版
NetWeaver ABAPCRM WebClient UIABAP エージェントビジネストランザクションと RUMRUM ベータ版
NetWeaver ABAPWebDynproABAP エージェントビジネストランザクションと RUM
NetWeaver ABAPWebGUI(SAPGUI for HTML)ABAP エージェントビジネストランザクションと RUMSAPGUI として検出されたビジネストランザクション

サポートされる SAP アプリケーションサーバのオペレーティングシステム

次の表に、HTTP SDK のローカルインストールが可能な、サポートされているオペレーティングシステムを示します。 

システムArchitecture

SAP でサポートされている Linux(Red Hat または SUSE)。glibc 2.11 以降を使用

コールグラフは glibc 2.22 からサポートされます

64 ビット(x86_64)
Microsoft Windows(4.4.1811 以降)64 ビット(x86_64)

オペレーティングシステムが混在する環境で実行されている複数のアプリケーションサーバがある SAP システム(Windows と Linux、Linux と AIX、または Windows と AIX など)はサポートされておらず、HTTP SDK のローカルインストールはできません。

1 つの SAP システムのすべてのアプリケーションサーバは、64 ビット Microsoft Windows または 64 ビット Linux で実行する必要があります。

選択的なアプリケーションサーバのインストゥルメンテーション、つまり、特定のアプリケーションサーバを ABAP エージェントの範囲から除外することは、現在サポートされていません。

サポートされていないアプリケーションサーバのオペレーティングシステムを使用する SAP システムの場合、HTTP SDK は別の 64 ビット Linux マシンにインストールする必要があります。「サポートされていない OS での SAP システムの展開」を参照してください。