On this page:

Related pages:

Systems that AppDynamics Database Visibility Supports

Once Database Visibility is available, you can create collectors that run on the Database Agent to monitor any of the following systems:

System Category

System Type

Supported via Amazon RDS

Version

Databases

 

 

 

 MongoDB, MongoDB cluster 2.2 and higher
 

MySQL

yes

all versions including Percona and MariaDB

 

Microsoft SQL Serveryes

2005, 2008, 2012, 2014, 2016 and SQL Azure

 

Microsoft SQL Server on Linux

 SQL Server on Linux is currently available as a public preview, and is not recommended for production use. Database Visibility works correctly with this preview release, but until a stable version of SQL Server on Linux is available, monitoring results may vary.
 Oracle, Oracle RACyes10g, 11g, and 12c

 

PostgreSQL

yes

all versions

 IBM DB2 LUW 9.x, 10.x, 11.x

 

Sybase ASE

 

15+

 Sybase IQ  
    

Hardware Monitoring

 

 

 

 Windows 

32-bit (will also work on 64-bit systems)

 Linux 32-bit and 64-bit

 

Solaris

 

all versions

 

AIX

 

 

 Amazon RDS  

To avoid metric value errors, use a 64-bit JRE with the 64-bit operating system.

If you use a third-party application along with Database Visibility to monitor Sybase, the data displayed in the controller may not display correctly. For accurate metrics, it is recommended that you do not use both a third-party application and Database Visibility to monitor Sybase.


Agent Hardware Requirements

Hardware requirements vary depending on database activity. If your database activity increases, you may need to adjust your hardware configuration.

The machine running the Database Agent should meet following hardware requirements:

Examples of heap space allocation:

AppDynamics Controller Sizing Requirements

The controller database should meet the following hardware requirements:

For information on additional hardware requirements for the AppDynamics Controller to support Database Visibility, see Controller System Requirements

The Database Agent requires the Events Service, which must be started before starting the agent.

Software Requirements

Network Requirements