Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: DOCS-4540
Appd tocbox

On this page:

Table of Contents
maxLevel3
minLevel3

The following tables describe This page describes the supported environments and versions for Browser RUM.

Excerpt

Browser RUM Support

Browser Compatibility

  • IE6/7/8/9/IE 10/11/Edge
  • Chrome 1.0.154.60 or later, including Mobile
  • Firefox, including Mobile 
  • Safari 4 or later, including Mobile
  • Opera 12 or later
Info

Browsers are rapidly evolving, and not all versions have been individually tested with Browser RUM. You can view the browser versions likely tosupport the Resource Timing API.

Browser Requirements for Sessions

To use Browser RUM sessions, your browser is required to support for the following:

Info

Browser RUM sessions do not support beacons implemented with GIFs.

JavaScript Agent Version Requirement for Sessions

You are required to use the JavaScript Agent 4.2+. Older versions of the JavaScript Agent do not support sessions.

Anchor
EUMandJava
EUMandJava
Injection Types for Browser RUM in Java Environments

Listed below are the injection types with their supported frameworks/technologies:

  • Automatic Injection: JavaServer Pages (JSP) compiled using the Jasper compiler. Jasper is the default JSP compiler in Tomcat, Glassfish, and JBoss.
  • Assisted Injection: All Servlet frameworks.
  • Manual Injection: All technologies that generate HTML pages.

See Configure Inject the JavaScript Agent for details.

Anchor
NETEUEM
NETEUEM
Injection Types for Browser RUM in .NET Environments

AppDynamics certifies Browser RUM instrumentation for the following .NET frameworks:

Web Application/ AJAX Frameworks

Versions

Additional Supported Script Injection Methods

ASP.NET Web Forms (.aspx)

3, 4

Automatic, Using Attribute Injection

ASP.NET MVC Web Forms (.aspx)

3, 4, 5

Automatic, Using Attribute Injection 

ASP.NET MVC Razor

3, 4, 5

Automatic, Using Attribute Injection

ASP.NET Core on the full .NET Framework4.0+Using Attribute Injection

Microsoft SharePoint

2007, 2010

Automatic

Info

AppDynamics does not support Browser RUM instrumentation of legacy ASP (.asp) pages.

Supported Runtime Environments for .NET Browser RUM

  • Microsoft IIS versions 6.0, 7.0, 7.5, 8.0, 8.5