AppDynamics Application Intelligence Platform

3.8.x Documentation

PDFs

Videos

Release Notes

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

Table of Contents
Excerpt

Supported Platform Matrix for the Standalone Machine Agent

The

Appd machine agent name
provides platform-level metrics. It has a default built-in plugin for hardware monitoring. See Install the Standalone Machine Agent.

JVM Requirements for the Standalone Machine Agent

The 

Appd machine agent name
 runs on a Java Virtual Machine.  JVMs versions 1.5 and higher are supported for most installations. If you are using AppDynamics Application Analytics, JVM 1.7 is required.

The

Appd machine agent name
should work with most, if not all the JVMs supported by the Java Agent; however the
Appd machine agent name
is only extensively tested with and fully supported on Oracle JDK and OpenJDK.

Supported Platforms for Default Hardware Monitor Plugin

Operating System

Architecture

Versions

Linux

x86

2.2, 2.4, 2.6 kernels

Linux

amd64

2.6 kernel

Linux

ppc

2.6 kernel

Linux

ppc64

2.6 kernel

Linux

ia64

2.6 kernel

Linux

s390

2.6 kernel

Linux

s390x

2.6 kernel

Solaris

Sparc-32

2.6, 7, 8, 9, 10

Solaris

Sparc-64

2.6, 7, 8, 9, 10

Solaris

x86

8, 9, 10

Solaris

x64

8, 9, 10

AIX

ppc

4.3, 5.1, 5.2, 5.3, 6.1

AIX

ppc64

5.2,5.3,6.1

HP-UX

PA-RISC

11

HP-UX

ia64

11

FreeBSD

x86

4.x

FreeBSD

x86

5.x, 6.x

FreeBSD

x64

6.x

FreeBSD

x86,x64

7.x,8.x

OpenBSD

x86

4.x,5.x

NetBSD

x86

3.1

Mac OS X

PowerPC

10.3, 10.4

Mac OS X

x86

10.4, 10.5, 10.6

Mac OS X

x64

10.5, 10.6

Windows

x86

NT 4.0, 2000 Pro/Server, 2003 Server, XP, Vista, 2008 Server, 7

Windows

x64

2003 Server, Vista, 2008 Server, 7

The following Linux distributions have been certified:

Distribution

Versions

Red Hat

6.2, 7.3, 8.0, 9.0

RHEL

3, 4, 5, 6

CentOS

3, 4, 5

Fedora

2, 3, 4, 5, 6, 7, 8, 9, 10

SuSE

8, 9, 10, 11

Ubuntu

6.06, 8.04, 8.10, 9.04

Debian

2.6, 3.0, 3.1, 3.2, 4.0, 5.0

VMware ESX

2.x, 3.0

XenServer

3.1, 3.2, 4.0, 4.1, 5.0

Slackware

10, 11

Mandrake

10

Scientific Linux

5

Gentoo

(info) Note: If you are using a 64-bit Operating System, use only a 64-bit Java Runtime Environment (JRE). For more details see Supported Platform Matrix for Default Hardware Monitoring Plugin.

...