Versions Compared

    Key

    • This line was added.
    • This line was removed.
    • Formatting was changed.

    ...

    Excerpt

    Standalone Machine Agent Supported Platforms

    Supported platforms and environments for the Standalone Machine Agent are dependent on which metric data collection extension is being used. This depends on the machine's OS. See Machine Agent Metric Collection for details.

    JRE Requirements

    The Standalone Machine Agent requires a Java Virtual Machine. JRE 1.8 or higher is required. Downloads for many of the supported OSs include Oracle JRE 1.8. The Standalone Machine Agent should work with most, if not all, of the JVMs supported by the Java Agent that are JRE 1.8 or higher. However, it is extensively tested only for the Oracle JDK and OpenJDK.

    Note the following about the available Machine Agent downloads:

    • For tested platforms listed in the following table, AppDynamics recommends using the bundled version of the 4.4 Standalone Machine Agent.
    • To run the Machine Agent on other platforms (such as AIX or HP-UX), use the unbundled Machine Agent ZIP without the JRE. The agent host must have JRE 1.8 installed.
    • If you are using a 64-bit Operating System, use only a 64-bit JRE. 
    Info

    A 64-bit long has a maximum and minimum value of 9223372036854775807 and -9223372036854775808, respectively, whereas a 32-bit long has a maximum and minimum value of 2147483647 and -2147483648, respectively. To handle large values for metrics, run the Machine Agent using a 64-bit JDK. 

    Bash Requirements

    Linux and SolarisagentsrequireBash 3.1 or higher.

    Required Libraries

    Linux systems must include the procps library.

    The following table provides instructions on how to install the library on some common flavorsofLinuxoperatingsystem.

    Div
    stylewidth: 100%;
    classmyTable
    Linux Flavor
    Command
    Red Hat and CentOS

    Use yum to install the library, such as:

    • yuminstallprocps
    FedoraInstall the library RPM from the Fedora website:
    • yuminstallprocps
    Ubuntu

    Use apt-get, such as:

    • sudoapt-getinstallprocps
    DebianUse a package manager such as APT to install the library (as described for the Ubuntu instructions above). 
    SUSE 12

    Use zypper to install the library, such as:

    • zypperinstallprocps

     

    Supported Environments

    Tested Platforms

     

    Div
    stylewidth: 100%;
    classmyTable

    OS

    Architecture

    Versions

     x86 (32-bit)x64 (64-bit)SPARC (64-bit) 

    Linux / CentOS

    Yes

    Yes 

    6

     Yes 7

    Linux / Debian

    Yes

    Yes 

    8

     Yes 9
    Linux / Fedora Yes 

    28

     Yes 29
    Linux / openSUSE Leap Yes 42.3
     Yes 15.0
    Linux / Red Hat Enterprise Linux

    Yes

    Yes 

    5

     Yes 6
     Yes 7
    Linux / SUSE Linux Enterprise Yes 11
     Yes 12
     Yes 15

    Linux / Ubuntu

    Yes

    Yes 

    14.04

    YesYes 16.04
     Yes 18.04
    Solaris

     

    YesYes

    10

     YesYes11

    Windows

     

    Yes 

    Windows Server 2012 R2

     Yes Windows Server 2016


    Other Platforms

    Other operating systems and versions that are supported by JRE 1.8 should also work, but are not fully tested by AppDynamics. 

    • Oracle JRE 1.8
    • IBM SDK, Java Technology Edition, Version 8 
    • HP JDK/JRE 8

    You should be able to run the Bundled version of the Standalone Machine Agent on machines based on Power Architecture processors, including PowerPC processors, but Server Visibility is not supported on these platforms.

    ...