Summary

AppDynamics has fixed a security issue introduced in Web Server Agent v4.2.3.0.

Affected Software

This issue was identified in all Web Server Agent versions between v4.2.3.0 and v4.2.6.0.

Impact

In v4.2.3.0, support for Virtual Hosts in Apache was added to the Web Server Agent. However, SSL connection requests between the Agent and Controller would fail when SSL was enabled within the Agent.

This issue did not impact any Web Servers Agents connected without SSL.

Resolution

Customers with Web Server Agents that require SSL should connect to the controller and update to 4.2.6.1, which contains the resolution for this issue. 

If upgrading to 4.2.6.1 is not viable, pre-4.2.3 agent versions that are 4.2.x should be sufficient.

  • No labels