Summary

There is a bug in the Node.js v8 profiler that causes memory leaks in Node.js versions 7 to 8.9.3. For more information, see the issue report: https://bugs.chromium.org/p/v8/issues/detail?id=6623 

Affected Software

This issue affects customers using Node.js versions 7 to 8.9.3.

Impact

Memory leaks may occur.

Resolution

Upgrade to Node.js version 8.9.4. Alternatively, set the maxProcessSnapshotsPerPeriod property to 0 in the require statement.

  • No labels