Summary

Upgrading the Controller to certain versions fails or, if successful, causes custom instrumentation rules to fail. 

Affected Software

This issue affects on-premises Controllers upgraded to version 4.2.6.1, 4.2.6.2, 4.2.7.0, 4.2.7.1, 4.2.8.0, and 4.2.8.1.

Impact

If you attempt to upgrade to an affected version, you may encounter one of two scenarios:

  • The upgrade fails with an error indicating "upgrade failed executing the upgrade script." 
    In this case, you need to contact support to resolve the issue. 
  • The upgrade succeeds, but new custom instrumentation rules (such as business transaction detection rules) cannot be added. Rules that existed prior to the upgrade will not work. 

Resolution

Avoid upgrading to an affected version if you have not already done so.

If you have already upgraded to an affected version, immediately upgrade to a version in which this issue is corrected, 4.2.8.2, or forthcoming releases 4.2.6.3, 4.2.7.2, and onwards.

  • No labels