On this page:

 

ここでは、エージェントとコントローラの各バージョン間の互換性マッピングについて説明します。 

エージェントとコントローラの互換性について

AppDynamics エージェントと AppDynamics コントローラの互換性については、以下の表「言語エージェントの下位互換性」を参照してください。 

モニタリング対象の環境では、すべてのエージェントにコントローラのバージョンと互換性があれば、指定した時間に異なるバージョンのエージェントをデプロイすることができます。ただし、最も古いエージェントは、すべてのビジネストランザクションの発生元階層にある必要があります。これにより、ダウンストリームノード上のエージェントが発生元階層で作成された相関ヘッダーを処理できるようになります。

エージェントのアップグレードをロールアウトする際に考慮すべき重要な点は、最初にダウンストリーム階層のノードでエージェントのアップグレードを開始してから、発生元階層ノードのエージェントを最後にアップグレードすることです。

言語エージェントの下位互換性

リリース 4.5 以降、AppDynamics 言語エージェントには 4.4.1 以降のコントローラとの下位互換性があります。これにより、言語エージェントをアップグレードし、最新のエージェント側の機能拡張、機能、バグ修正を利用できます。4.4 コントローラをアップグレードする必要はありません。次の表に、互換性のあるコントローラと言語エージェントのリリースの概要を示します。

Controller Release言語エージェントのリリース備考
4.5.x4.1+4.5.x コントローラは 4.1 以降のエージェントからの接続を受け入れることができます。
4.4.1+4.1+4.4.1 以降のコントローラは、新しいエージェントからの接続を受け入れることができます。
4.3.x4.1.x ~ 4.3.x4.3.x コントローラは、新しいエージェントからの接続を受け入れることができません。
4.2.x4.1.x ~ 4.2.x4.3 以前のエージェントのサポートを終了し、4.1 以前のエージェントはコントローラへの接続が保証されなくなります。

下位互換性は、リリース 4.5 以降の次のエージェントでサポートされています。

  • Java
  • .NET
  • Node.js
  • PHP
  • Python
  • C/C++
  • Go SDK

Enterprise Console を使用してコントローラをアップグレードするときに、いくつかのフォルダ(appagent フォルダを含む)が削除され、再インストールされます。controller/appserver/glassfish/domains/domain1/appagentフォルダ内のコントローラよりも新しいバージョンを使用して Java エージェントをデプロイした場合、アップグレードは失敗し、内部モニタリングは失われます。これを防止するには、domain.xml ファイルを更新して新しい Java エージェントを指定するか、Java エージェントにカスタマイズされたインストールを使用しないようにする必要があります。

エージェントとコントローラの各バージョン間の SSL プロトコルの互換性に関する注意事項については、「 Java とコントローラのアプリケーション エージェントに対する SSL 互換性マトリックス」を参照してください。

コントローラバージョン 4.5.x でサポートされるエージェントのバージョン

エージェントのバージョン/
エージェントのタイプ
言語エージェントデータベースエージェントAppDynamics for Databasesマシンエージェントネットワークエージェント
Javaエージェント.NETエージェントNode.jsエージェントPHPエージェントPythonエージェントWeb サーバエージェントC/C++ Agent(SDK)
4.5.x 
4.4.x 
4.3.x  
4.2.x    
4.1.x     
4.0.3          
2.7.4 以降          
Linux バージョン 4.5.9 の .NET エージェントでサポートされているビジネストランザクション検出をカスタマイズする機能には、4.5.2 以上のバージョンのコントローラが必要です。.NET エージェントバージョン 4.5.9 は、コントローラバージョン 4.4.1 以降で動作しますが、カスタマイズ可能なトランザクション検出および設定機能には、コントローラの 4.5.2 以降のバージョンが必要です。次を参照してください。Linux ビジネストランザクション設定用の .NET エージェント

 

Java エージェントとコントローラ間の SSL 互換性

コントローラで使用されるデフォルトのプロトコルは TLSv1.2 です。コントローラまたはエージェントで使用されるデフォルトのセキュリティプロトコルを変更する方法については、「プラットフォームの保護」を参照してください。 

Java エージェントの場合、デフォルトのプロトコルは次のとおりです。

  • Java 8 SE アプリケーションの場合:TLSv1.2。
  • Java 7 以降のアプリケーションの場合:TLSv1.2。

CVE-2014-3566 の脆弱性に伴い、SSLv3 は SaaS コントローラでは無効になっています。したがって、SSLv3 の接続は今後サポートされません。

新しいエージェント機能の導入

新しいエージェントと古いエージェントが同じ最新のコントローラでサポートされている場合でも、以降のエージェントで導入された新機能は、古いエージェントでは使用できません。

エージェント機能が導入されたタイミングに関する情報は、新しいメジャーリリース(4.5 など)については「新機能および拡張」セクションに記載されています。また、マイナーリリースについては、リリースノートの「<minor_release_number> の更新」セクションに記載されています。